force use of pandoc version >= 3.1.12.2
The `bin/pandoc-wrapper.sh` tool will verify that the ssytem has a recent enough version of `pandoc(1)`. We explain why we insist on `pandoc(1)`. version >= 3.1.12.2 in comments where the $PANDOC_MIN_VERSION is set. Added `--wrap=preserve` as a default argument to `pandoc(1)`. While this change will impact every HTML file generated, we believe this will improve the ability of someone to look at the generated HTML and correlate with the original markdown. Changed `bin/pandoc-wrapper.sh` VERSION from "1.4.2 2024-03-17" to "1.4.3 2024-03-18". Performed `make www` to achieve all of the above and to generate HTML using the new `--wrap=preserve` `pandoc(1)` mode.
This commit is contained in:
1 parent
9eb7a54e9f
commit
b0b212acb1
402 files changed
+37061
-55132
No files matched your search
+100
-177
@@ -129,9 +129,9 @@
|
||||
|
||||
<h2 id="authors"><a name="author"></a>Authors:</h2>
|
||||
<ul>
|
||||
<li>Name: <a href="../../authors.html#Anonymous_2015">Anonymous
|
||||
2015</a><br> Location: <a href="../../location.html#JP">JP</a> -
|
||||
<em>Japan</em> <br><br></li>
|
||||
<li>Name: <a href="../../authors.html#Anonymous_2015">Anonymous 2015</a><br>
|
||||
Location: <a href="../../location.html#JP">JP</a> - <em>Japan</em>
|
||||
<br><br></li>
|
||||
<li>Name: <a href="../../authors.html#Yusuke_Endoh">Yusuke Endoh</a><br>
|
||||
Location: <a href="../../location.html#JP">JP</a> - <em>Japan</em>
|
||||
<br><br></li>
|
||||
@@ -144,31 +144,27 @@ Location: <a href="../../location.html#JP">JP</a> - <em>Japan</em>
|
||||
|
||||
<h2 id="to-build">To build:</h2>
|
||||
<div class="sourceCode" id="cb1"><pre class="sourceCode sh"><code class="sourceCode bash"><span id="cb1-1"><a href="#cb1-1" aria-hidden="true" tabindex="-1"></a><span class="fu">make</span></span></code></pre></div>
|
||||
<p>NOTE: this program requires the tool <code>tcpserver</code> to use.
|
||||
If you do not have this program see <a
|
||||
href="../../faq.html#tcpserver">FAQ 3.14 - How do I compile and install
|
||||
tcpserver for entries that require it</a>.</p>
|
||||
<p>NOTE: this program requires the tool <code>tcpserver</code> to use. If you do not have this
|
||||
program see <a href="../../faq.html#tcpserver">FAQ 3.14 - How do I compile and install tcpserver for entries that
|
||||
require it</a>.</p>
|
||||
<h2 id="to-use">To use:</h2>
|
||||
<div class="sourceCode" id="cb2"><pre class="sourceCode sh"><code class="sourceCode bash"><span id="cb2-1"><a href="#cb2-1" aria-hidden="true" tabindex="-1"></a><span class="ex">tcpserver</span> <span class="at">-v</span> 127.0.0.1 10333 ./prog ioccc.txt</span></code></pre></div>
|
||||
<p>Then connect to http://localhost:10333 with your browser.</p>
|
||||
<h2 id="judges-remarks">Judges’ remarks:</h2>
|
||||
<p><a href="https://www.livescience.com/950-leopard-spots.html">How did
|
||||
the leopard get its spots</a>? Why are a <a
|
||||
href="https://africafreak.com/zebra-stripes">zebra’s stripes</a>
|
||||
unique?</p>
|
||||
<p>In case you didn’t recognise the portrait of <a
|
||||
href="https://en.wikipedia.org/wiki/Alan_Turing">Alan Turing</a>, there
|
||||
are some pointers to his features like eyes with “<code>stdeye-o</code>”
|
||||
and “<code><--mouth</code>”. Can you find any other tributes?</p>
|
||||
<p><a href="https://www.livescience.com/950-leopard-spots.html">How did the leopard get its
|
||||
spots</a>? Why are a <a href="https://africafreak.com/zebra-stripes">zebra’s
|
||||
stripes</a> unique?</p>
|
||||
<p>In case you didn’t recognise the portrait of <a href="https://en.wikipedia.org/wiki/Alan_Turing">Alan
|
||||
Turing</a>, there are some
|
||||
pointers to his features like eyes with “<code>stdeye-o</code>” and “<code><--mouth</code>”. Can you
|
||||
find any other tributes?</p>
|
||||
<h2 id="authors-remarks">Author’s remarks:</h2>
|
||||
<p>What does “<a href="https://en.wikipedia.org/wiki/Alan_Turing">Alan
|
||||
Turing</a>” remind you of? <a
|
||||
href="https://en.wikipedia.org/wiki/Cryptanalysis">Cryptanalysis</a> of
|
||||
the <a href="https://en.wikipedia.org/wiki/Enigma_machine">Enigma
|
||||
machine</a>? <a
|
||||
href="https://en.wikipedia.org/wiki/Turing_machine">Turing machine</a>?
|
||||
<a href="https://en.wikipedia.org/wiki/Turing_test">Turing test</a>?
|
||||
This program is also based on his work.</p>
|
||||
<p>What does “<a href="https://en.wikipedia.org/wiki/Alan_Turing">Alan Turing</a>” remind you
|
||||
of? <a href="https://en.wikipedia.org/wiki/Cryptanalysis">Cryptanalysis</a> of the <a href="https://en.wikipedia.org/wiki/Enigma_machine">Enigma
|
||||
machine</a>? <a href="https://en.wikipedia.org/wiki/Turing_machine">Turing
|
||||
machine</a>? <a href="https://en.wikipedia.org/wiki/Turing_test">Turing
|
||||
test</a>? This program is also based on
|
||||
his work.</p>
|
||||
<h3 id="whirlwind-tour">Whirlwind tour</h3>
|
||||
<p>Compile the program as follows:</p>
|
||||
<div class="sourceCode" id="cb3"><pre class="sourceCode sh"><code class="sourceCode bash"><span id="cb3-1"><a href="#cb3-1" aria-hidden="true" tabindex="-1"></a><span class="fu">cc</span> <span class="at">-O3</span> <span class="at">-std</span><span class="op">=</span>c99 <span class="dt">\</span></span>
|
||||
@@ -178,83 +174,65 @@ This program is also based on his work.</p>
|
||||
<span id="cb3-5"><a href="#cb3-5" aria-hidden="true" tabindex="-1"></a> <span class="at">-DF</span><span class="op">=</span>0.040 <span class="at">-DK</span><span class="op">=</span>0.060 <span class="at">-DDu</span><span class="op">=</span>0.200 <span class="at">-DDv</span><span class="op">=</span>0.100 <span class="dt">\</span></span>
|
||||
<span id="cb3-6"><a href="#cb3-6" aria-hidden="true" tabindex="-1"></a> <span class="at">-DUV_BACKGROUND</span><span class="op">=</span>1,0 <span class="at">-DUV_DROP</span><span class="op">=</span>-0.5,0.5 <span class="dt">\</span></span>
|
||||
<span id="cb3-7"><a href="#cb3-7" aria-hidden="true" tabindex="-1"></a> <span class="at">-DTIMESTEP</span><span class="op">=</span>1.0 <span class="at">-DSPEED</span><span class="op">=</span>2 <span class="at">-DRGB</span><span class="op">=</span>255:128:192</span></code></pre></div>
|
||||
<p>Then, run it with the <code>tcpserver</code> command in the <a
|
||||
href="http://cr.yp.to/ucspi-tcp.html">ucspi-tcp</a> package, which was
|
||||
created by <a href="../../authors.html#Daniel_J_Bernstein">Daniel J.
|
||||
Bernstein</a>’s <a href="../../1991/brnstnd/index.html">1991/brndstd</a>
|
||||
“Best of Show”.</p>
|
||||
<p>Then, run it with the <code>tcpserver</code> command in the
|
||||
<a href="http://cr.yp.to/ucspi-tcp.html">ucspi-tcp</a> package, which was created by
|
||||
<a href="../../authors.html#Daniel_J_Bernstein">Daniel J. Bernstein</a>’s
|
||||
<a href="../../1991/brnstnd/index.html">1991/brndstd</a> “Best of Show”.</p>
|
||||
<div class="sourceCode" id="cb4"><pre class="sourceCode sh"><code class="sourceCode bash"><span id="cb4-1"><a href="#cb4-1" aria-hidden="true" tabindex="-1"></a><span class="ex">tcpserver</span> <span class="at">-v</span> 127.0.0.1 10333 ./prog ioccc.txt</span></code></pre></div>
|
||||
<p>Finally, open <code>http://127.0.0.1:10333/</code> in a modern
|
||||
browser supporting HTML5. You can use the mouse cursor to place drops
|
||||
into the <a href="https://en.wikipedia.org/wiki/Petri_dish">Petri
|
||||
<p>Finally, open <code>http://127.0.0.1:10333/</code> in a modern browser supporting HTML5.
|
||||
You can use the mouse cursor to place drops into the <a href="https://en.wikipedia.org/wiki/Petri_dish">Petri
|
||||
dish</a> interactively.</p>
|
||||
<h3 id="description">Description</h3>
|
||||
<p>This is a simulator of <a
|
||||
href="https://en.wikipedia.org/wiki/Reaction-diffusion_system">reaction-diffusion
|
||||
<p>This is a simulator of <a href="https://en.wikipedia.org/wiki/Reaction-diffusion_system">reaction-diffusion
|
||||
systems</a>.</p>
|
||||
<p>Reaction-diffusion systems, proposed by Alan Turing in <a href="#fn1"
|
||||
class="footnote-ref" id="fnref1" role="doc-noteref"><sup>1</sup></a>,
|
||||
are mathematical models in which two chemical substances are transformed
|
||||
into each other (<em>local chemical reactions</em>) and spread out
|
||||
(<em>diffusion</em>). Their interactions sometimes form non-trivial
|
||||
patterns, such as spots, spiral, dappling, and labyrinths.</p>
|
||||
<p>Reaction-diffusion systems, proposed by Alan Turing in <a href="#fn1" class="footnote-ref" id="fnref1" role="doc-noteref"><sup>1</sup></a>, are mathematical
|
||||
models in which two chemical substances are transformed into each other (<em>local
|
||||
chemical reactions</em>) and spread out (<em>diffusion</em>). Their interactions sometimes
|
||||
form non-trivial patterns, such as spots, spiral, dappling, and labyrinths.</p>
|
||||
<p>The systems are generally formulated as follows:</p>
|
||||
<pre><code>du/dt = F(u, v) + Du * laplacian(u)
|
||||
dv/dt = G(u, v) + Dv * laplacian(v)</code></pre>
|
||||
<p>The functions <code>F(u, v)</code> and <code>G(u, v)</code> represent
|
||||
reactions of each substance, and the parameters <code>Du</code> and
|
||||
<code>Dv</code> are diffusion coefficients. By changing the functions
|
||||
and parameters, you can see a wide range of behaviors.</p>
|
||||
<p>See <a
|
||||
href="https://en.wikipedia.org/wiki/Reaction%E2%80%93diffusion_system">the
|
||||
Wikipedia article of “Reaction-diffusion system”</a> in detail.</p>
|
||||
<p>This program simulates the systems. The field consists of 128 x 128
|
||||
cells. Each cell includes information of an amount of the two
|
||||
substances, and interacts with neighbor cells (in terms of <a
|
||||
href="https://en.wikipedia.org/wiki/Von_Neumann_neighborhood">von
|
||||
Neumann neighborhood</a>) in each frame.</p>
|
||||
<p>The functions <code>F(u, v)</code> and <code>G(u, v)</code> represent reactions of each substance, and
|
||||
the parameters <code>Du</code> and <code>Dv</code> are diffusion coefficients. By changing the
|
||||
functions and parameters, you can see a wide range of behaviors.</p>
|
||||
<p>See <a href="https://en.wikipedia.org/wiki/Reaction%E2%80%93diffusion_system">the Wikipedia article of “Reaction-diffusion
|
||||
system”</a> in
|
||||
detail.</p>
|
||||
<p>This program simulates the systems. The field consists of 128 x 128 cells.
|
||||
Each cell includes information of an amount of the two substances, and interacts
|
||||
with neighbor cells (in terms of <a href="https://en.wikipedia.org/wiki/Von_Neumann_neighborhood">von Neumann
|
||||
neighborhood</a>) in each frame.</p>
|
||||
<h3 id="configuration">Configuration</h3>
|
||||
<p>You can change the model, initial pattern, simulation speed, and
|
||||
color via macro definition.</p>
|
||||
<h4 id="model--delta_uexpression--delta_vexpression">Model:
|
||||
<code>-Delta_u=<expression> -Delta_v=<expression></code></h4>
|
||||
<p>The definitions represent the equations of reaction-diffusion system.
|
||||
For example, the following is <a
|
||||
href="http://groups.csail.mit.edu/mac/projects/amorphous/GrayScott/">the
|
||||
Gray-Scott model</a> in TeX notation.</p>
|
||||
<p>You can change the model, initial pattern, simulation speed, and color via macro
|
||||
definition.</p>
|
||||
<h4 id="model--delta_uexpression--delta_vexpression">Model: <code>-Delta_u=<expression> -Delta_v=<expression></code></h4>
|
||||
<p>The definitions represent the equations of reaction-diffusion system. For
|
||||
example, the following is <a href="http://groups.csail.mit.edu/mac/projects/amorphous/GrayScott/">the Gray-Scott
|
||||
model</a> in TeX
|
||||
notation.</p>
|
||||
<pre><code>\frac{\partial u}{\partial t} = D_u \Delta u - u v^2 + F (1 - u)
|
||||
\frac{\partial v}{\partial t} = D_v \Delta v + u v^2 - v (F + K)</code></pre>
|
||||
<p>You can specify this model as follows:</p>
|
||||
<pre><code>-Delta_u="Du*laplacian(u)-u*v*v+F*(1-u)" \
|
||||
-Delta_v="Dv*laplacian(v)+u*v*v-v*(F+K)"</code></pre>
|
||||
<p><code>Du</code>, <code>Dv</code>, <code>F</code>, and <code>K</code>
|
||||
are parameters of that model.</p>
|
||||
<h4 id="initial-pattern--duv_backgroundu0v0--duv_dropu1v1">Initial
|
||||
pattern:
|
||||
<code>-DUV_BACKGROUND=<u0>,<v0> -DUV_DROP=<u1>,<v1></code></h4>
|
||||
<p>The definitions specifies the initial amount of the two substances
|
||||
<code>u</code> and <code>v</code>. All cells have <code>(u0, v0)</code>
|
||||
by default.</p>
|
||||
<p><code>Du</code>, <code>Dv</code>, <code>F</code>, and <code>K</code> are parameters of that model.</p>
|
||||
<h4 id="initial-pattern--duv_backgroundu0v0--duv_dropu1v1">Initial pattern: <code>-DUV_BACKGROUND=<u0>,<v0> -DUV_DROP=<u1>,<v1></code></h4>
|
||||
<p>The definitions specifies the initial amount of the two substances <code>u</code> and <code>v</code>.
|
||||
All cells have <code>(u0, v0)</code> by default.</p>
|
||||
<p>You can specify a pattern file when the executable is invoked (not
|
||||
compile-time). The file should include a sequence of points, see <a
|
||||
href="ioccc.txt">ioccc.txt</a>, <a href="center.txt">center.txt</a>, or
|
||||
<a href="line.txt">line.txt</a> as examples. Each amount in cells near
|
||||
to the point included in the file, will be added by
|
||||
<code>(u1, v1)</code>.</p>
|
||||
<h4 id="simulation-speed--dtimestepts--dspeedspd">Simulation speed:
|
||||
<code>-DTIMESTEP=ts -DSPEED=spd</code></h4>
|
||||
compile-time). The file should include a sequence of points, see
|
||||
<a href="ioccc.txt">ioccc.txt</a>, <a href="center.txt">center.txt</a>, or <a href="line.txt">line.txt</a> as
|
||||
examples. Each amount in cells near to the point included in the file, will be
|
||||
added by <code>(u1, v1)</code>.</p>
|
||||
<h4 id="simulation-speed--dtimestepts--dspeedspd">Simulation speed: <code>-DTIMESTEP=ts -DSPEED=spd</code></h4>
|
||||
<p>The definitions are for changing the simulation speed.</p>
|
||||
<p><code>TIMESTEP</code> is a simulation time step. The bigger, the
|
||||
faster but more unstable.</p>
|
||||
<p><code>SPEED</code> is a frame skip parameter. The bigger, the faster
|
||||
but more sluggish.</p>
|
||||
<h4 id="rendering-color--drgbrgb">Rendering color:
|
||||
<code>-DRGB=r:g:b</code></h4>
|
||||
<p><code>TIMESTEP</code> is a simulation time step. The bigger, the faster but more unstable.</p>
|
||||
<p><code>SPEED</code> is a frame skip parameter. The bigger, the faster but more sluggish.</p>
|
||||
<h4 id="rendering-color--drgbrgb">Rendering color: <code>-DRGB=r:g:b</code></h4>
|
||||
<p>This specifies a color used for rendering.</p>
|
||||
<h3 id="examples">Examples</h3>
|
||||
<p>Some interesting parameters are included in <code>Makefile</code>. Do
|
||||
one of the following commands and open
|
||||
<code>http://127.0.0.1:10333</code>.</p>
|
||||
<p>Some interesting parameters are included in <code>Makefile</code>. Do one of the following
|
||||
commands and open <code>http://127.0.0.1:10333</code>.</p>
|
||||
<pre><code>make gray-scott-1 && tcpserver -v 127.0.0.1 10333 ./gray-scott-1 ioccc.txt
|
||||
make gray-scott-1 && tcpserver -v 127.0.0.1 10333 ./gray-scott-1 center.txt
|
||||
make gray-scott-1 && tcpserver -v 127.0.0.1 10333 ./gray-scott-1 line.txt
|
||||
@@ -264,51 +242,38 @@ make gray-scott-4 && tcpserver -v 127.0.0.1 10333 ./gray-scott-4 ioccc.t
|
||||
make fitzhugh-nagumo-1 && tcpserver -v 127.0.0.1 10333 ./fitzhugh-nagumo-1 ioccc.txt
|
||||
make fitzhugh-nagumo-2 && tcpserver -v 127.0.0.1 10333 ./fitzhugh-nagumo-2 ioccc.txt
|
||||
make oregonator && tcpserver -v 127.0.0.1 10333 ./oregonator ioccc.txt</code></pre>
|
||||
<p>These examples are created by drawing (and modifying) the pattern
|
||||
files of <a href="https://github.com/GollyGang/ready">Ready</a>, a
|
||||
cross-platform implementation of various reaction-diffusion systems <a
|
||||
href="#fn2" class="footnote-ref" id="fnref2"
|
||||
role="doc-noteref"><sup>2</sup></a>.</p>
|
||||
<p>These examples are created by drawing (and modifying) the pattern files of
|
||||
<a href="https://github.com/GollyGang/ready">Ready</a>, a cross-platform implementation of
|
||||
various reaction-diffusion systems <a href="#fn2" class="footnote-ref" id="fnref2" role="doc-noteref"><sup>2</sup></a>.</p>
|
||||
<h3 id="compatibility">Compatibility</h3>
|
||||
<h4 id="c-part">C part</h4>
|
||||
<p>This program compiles clean with no warnings under
|
||||
<code>-std=c99 -Wall -Wextra -pedantic</code>. Since it uses
|
||||
<code>long long</code> for 64bit integers, C99 is required.</p>
|
||||
<p>This program compiles clean with no warnings under <code>-std=c99 -Wall -Wextra -pedantic</code>. Since it uses <code>long long</code> for 64bit integers, C99 is required.</p>
|
||||
<h4 id="browser-part">Browser part</h4>
|
||||
<p>You must use a modern browser that supports the latest specification
|
||||
of WebSocket <a href="#fn3" class="footnote-ref" id="fnref3"
|
||||
role="doc-noteref"><sup>3</sup></a>. All the following browsers worked
|
||||
for me:</p>
|
||||
<p>You must use a modern browser that supports the latest specification of
|
||||
WebSocket <a href="#fn3" class="footnote-ref" id="fnref3" role="doc-noteref"><sup>3</sup></a>. All the following browsers worked for me:</p>
|
||||
<ul>
|
||||
<li>Google Chrome 45</li>
|
||||
<li>Mozilla Firefox 39</li>
|
||||
<li>Microsoft Internet Explorer 11 (works but sluggish)</li>
|
||||
</ul>
|
||||
<p>I think Safari 6 will work but I haven’t tested. (I have no recent
|
||||
macOS.)</p>
|
||||
<p>NOTE from the judges in 2023: recent versions of Safari also
|
||||
work.</p>
|
||||
<p>I think Safari 6 will work but I haven’t tested. (I have no recent macOS.)</p>
|
||||
<p>NOTE from the judges in 2023: recent versions of Safari also work.</p>
|
||||
<h4 id="tcpserver-alternatives">tcpserver alternatives</h4>
|
||||
<p>I think you may use <code>inetd</code> and <code>xinetd</code>
|
||||
instead of <code>tcpserver</code>. Here is an example <code>inetd</code>
|
||||
configuration.</p>
|
||||
<p>I think you may use <code>inetd</code> and <code>xinetd</code> instead of <code>tcpserver</code>. Here is an
|
||||
example <code>inetd</code> configuration.</p>
|
||||
<pre><code>10333 stream tcp nowait nobody /path/to/prog /path/to/prog /path/to/initial-pattern.txt</code></pre>
|
||||
<p>But note that I didn’t test well.</p>
|
||||
<h3 id="internal">Internal</h3>
|
||||
<ol type="1">
|
||||
<li>The C program accepts HTTP connection from the browser, and sends a
|
||||
HTML document.</li>
|
||||
<li>The C program accepts HTTP connection from the browser, and sends a HTML
|
||||
document.</li>
|
||||
<li>The browser tries to upgrade the connection to WebSocket.</li>
|
||||
<li>The C program accepts WebSocket upgrade. This negotiation process
|
||||
requires SHA1 hash <a href="#fn4" class="footnote-ref" id="fnref4"
|
||||
role="doc-noteref"><sup>4</sup></a> and Base64 encoding <a href="#fn5"
|
||||
class="footnote-ref" id="fnref5" role="doc-noteref"><sup>5</sup></a>.
|
||||
The C program calculates them without the aid of any external
|
||||
libraries.</li>
|
||||
<li>The C program simulates the reaction-diffusion system, and then send
|
||||
the field data to the browser on each frame.</li>
|
||||
<li>The browser receives and renders the field data onto the HTML5
|
||||
canvas.</li>
|
||||
<li>The C program accepts WebSocket upgrade. This negotiation process requires
|
||||
SHA1 hash <a href="#fn4" class="footnote-ref" id="fnref4" role="doc-noteref"><sup>4</sup></a> and Base64 encoding <a href="#fn5" class="footnote-ref" id="fnref5" role="doc-noteref"><sup>5</sup></a>. The C program calculates them without
|
||||
the aid of any external libraries.</li>
|
||||
<li>The C program simulates the reaction-diffusion system, and then send the
|
||||
field data to the browser on each frame.</li>
|
||||
<li>The browser receives and renders the field data onto the HTML5 canvas.</li>
|
||||
</ol>
|
||||
<h3 id="references">References</h3>
|
||||
<ul>
|
||||
@@ -318,41 +283,19 @@ canvas.</li>
|
||||
<li></li>
|
||||
<li></li>
|
||||
</ul>
|
||||
<h2 id="copyright-and-cc-by-sa-4.0-license">Copyright and CC BY-SA 4.0
|
||||
License:</h2>
|
||||
<p>This file is Copyright (c) 2023 by Landon Curt Noll. All Rights
|
||||
Reserved. You are free to share and adapt this file under the terms of
|
||||
this license:</p>
|
||||
<h2 id="copyright-and-cc-by-sa-4.0-license">Copyright and CC BY-SA 4.0 License:</h2>
|
||||
<p>This file is Copyright (c) 2023 by Landon Curt Noll. All Rights Reserved.
|
||||
You are free to share and adapt this file under the terms of this license:</p>
|
||||
<pre><code>Creative Commons Attribution-ShareAlike 4.0 International (CC BY-SA 4.0)</code></pre>
|
||||
<p>For more information, see:
|
||||
https://creativecommons.org/licenses/by-sa/4.0/</p>
|
||||
<section id="footnotes" class="footnotes footnotes-end-of-document"
|
||||
role="doc-endnotes">
|
||||
<p>For more information, see: https://creativecommons.org/licenses/by-sa/4.0/</p>
|
||||
<section id="footnotes" class="footnotes footnotes-end-of-document" role="doc-endnotes">
|
||||
<hr />
|
||||
<ol>
|
||||
<li id="fn1"><p>Turing, A. M., “The Chemical Basis of Morphogenesis”,
|
||||
Philosophical Transactions of the Royal Society, 1952.<a href="#fnref1"
|
||||
class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn2"><p>The Ready Bunch, “Ready”, A cross-platform
|
||||
implementation of various reaction-diffusion systems, since 2011, <a
|
||||
href="https://github.com/GollyGang/ready"
|
||||
class="uri">https://github.com/GollyGang/ready</a>.<a href="#fnref2"
|
||||
class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn3"><p>Fette, I. and A. Melnikov, “The WebSocket Protocol”, RFC
|
||||
6455, DOI 10.17487/RFC6455, December 2011, <a
|
||||
href="http://www.rfc-editor.org/info/rfc6455"
|
||||
class="uri">http://www.rfc-editor.org/info/rfc6455</a>.<a href="#fnref3"
|
||||
class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn4"><p>Eastlake 3rd, D. and P. Jones, “US Secure Hash Algorithm
|
||||
1 (SHA1)”, RFC 3174, DOI 10.17487/RFC3174, September 2001, <a
|
||||
href="http://www.rfc-editor.org/info/rfc3174"
|
||||
class="uri">http://www.rfc-editor.org/info/rfc3174</a>.<a href="#fnref4"
|
||||
class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn5"><p>Josefsson, S., “The Base16, Base32, and Base64 Data
|
||||
Encodings”, RFC 4648, DOI 10.17487/RFC4648, October 2006, <a
|
||||
href="http://www.rfc-editor.org/info/rfc4648"
|
||||
class="uri">http://www.rfc-editor.org/info/rfc4648</a>.<a href="#fnref5"
|
||||
class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn1"><p>Turing, A. M., “The Chemical Basis of Morphogenesis”, Philosophical Transactions of the Royal Society, 1952.<a href="#fnref1" class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn2"><p>The Ready Bunch, “Ready”, A cross-platform implementation of various reaction-diffusion systems, since 2011, <a href="https://github.com/GollyGang/ready" class="uri">https://github.com/GollyGang/ready</a>.<a href="#fnref2" class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn3"><p>Fette, I. and A. Melnikov, “The WebSocket Protocol”, RFC 6455, DOI 10.17487/RFC6455, December 2011, <a href="http://www.rfc-editor.org/info/rfc6455" class="uri">http://www.rfc-editor.org/info/rfc6455</a>.<a href="#fnref3" class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn4"><p>Eastlake 3rd, D. and P. Jones, “US Secure Hash Algorithm 1 (SHA1)”, RFC 3174, DOI 10.17487/RFC3174, September 2001, <a href="http://www.rfc-editor.org/info/rfc3174" class="uri">http://www.rfc-editor.org/info/rfc3174</a>.<a href="#fnref4" class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
<li id="fn5"><p>Josefsson, S., “The Base16, Base32, and Base64 Data Encodings”, RFC 4648, DOI 10.17487/RFC4648, October 2006, <a href="http://www.rfc-editor.org/info/rfc4648" class="uri">http://www.rfc-editor.org/info/rfc4648</a>.<a href="#fnref5" class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
</ol>
|
||||
</section>
|
||||
|
||||
@@ -361,45 +304,25 @@ class="footnote-back" role="doc-backlink">↩︎</a></p></li>
|
||||
|
||||
<!-- START: this line starts content generated by: bin/output-index-inventory.sh -->
|
||||
|
||||
<h1 id="inventory-for-2015endoh1"><a name="inventory"></a>Inventory for
|
||||
2015/endoh1</h1>
|
||||
<h1 id="inventory-for-2015endoh1"><a name="inventory"></a>Inventory for 2015/endoh1</h1>
|
||||
<p><a href="#top">Jump to top</a></p>
|
||||
<h2 id="primary-files">Primary files</h2>
|
||||
<ul>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/prog.c">prog.c</a>
|
||||
- entry source</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/Makefile">Makefile</a>
|
||||
- entry Makefile</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/prog.orig.c">prog.orig.c</a>
|
||||
- original source</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/center.txt">center.txt</a>
|
||||
- sample input</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/ioccc.txt">ioccc.txt</a>
|
||||
- sample input</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/line.txt">line.txt</a>
|
||||
- sample input</li>
|
||||
<li><a href="2015_endoh1.tar.bz2">2015_endoh1.tar.bz2</a> - download
|
||||
entry source</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/prog.c">prog.c</a> - entry source</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/Makefile">Makefile</a> - entry Makefile</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/prog.orig.c">prog.orig.c</a> - original source</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/center.txt">center.txt</a> - sample input</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/ioccc.txt">ioccc.txt</a> - sample input</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/line.txt">line.txt</a> - sample input</li>
|
||||
<li><a href="2015_endoh1.tar.bz2">2015_endoh1.tar.bz2</a> - download entry source</li>
|
||||
</ul>
|
||||
<h2 id="secondary-files">Secondary files</h2>
|
||||
<ul>
|
||||
<li><a href="index.html">index.html</a> - entry home page</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/.entry.json">.entry.json</a>
|
||||
- description of entry in JSON</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/.gitignore">.gitignore</a>
|
||||
- list of files that should not be committed under git</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/.entry.json">.entry.json</a> - description of entry in JSON</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/.gitignore">.gitignore</a> - list of files that should not be committed under git</li>
|
||||
<li><a href=".path">.path</a> - directory path from top directory</li>
|
||||
<li><a
|
||||
href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/README.md">README.md</a>
|
||||
- markdown source for index.html</li>
|
||||
<li><a href="https://github.com/ioccc-src/temp-test-ioccc/blob/master/2015/endoh1/README.md">README.md</a> - markdown source for index.html</li>
|
||||
</ul>
|
||||
|
||||
<!-- END: next line ends content generated by: bin/output-index-inventory.sh -->
|
||||
|
||||
Reference in new issue
Block a user